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 4Road to the Metaverse -> Welcome to the metaverse: Your journey starts here

Agenda

Survey available here!

→ Introduction (5 minutes)

→ Augmenting Reality: Bring digital objects into the real world 

(45 minutes)

‒ What is AR?

‒ AR platforms overview

‒ Getting started with AR Foundations in Unity!

→ Q&A + Wrap-up (10 minutes)

→ Overtime! (30 minutes)

‒ MRTK

‒ The Future of AR
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Introduction

Tales from the Metaverse!
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https://docs.google.com/file/d/1TxvMWeUc_gFNxn2HWSKv-W3GVMpeNsvv/preview


Road to the Metaverse  7

The Metaverse 
Minute
https://blog.unity.com/topic/metaverse-minute

https://blog.unity.com/topic/metaverse-minute


Road to the Metaverse  8

Road to the Metaverse: 
Forums!
https://forum.unity.com/forums/road-to-the-metaverse.798/

https://forum.unity.com/forums/road-to-the-metaverse.798/
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Augmenting reality: Bring digital 
objects into the real world

C R E A T O R   S E R I E S



What is XR?

Road to the Metaverse 

What is XR? It's shorthand for a related set of new 
technologies that are changing the way we interact with 
the world and with each other: Virtual Reality, Augmented 
Reality, and Mixed Reality. 

● VR - Virtual Reality
● MR - Mixed Reality
● AR - Augmented Reality
● XR - Umbrella term for all the above

Unity Learn Intro to XR
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https://learn.unity.com/course/introduction-to-xr-vr-ar-and-mr-foundations


What is AR?

 11An introduction to AR, VR, MR, XR and more



What is XR? -> Demo  12

Let’s jump in!
What is AR?



PTC

Vuforia

Vuforia Demo  13

Download the SDK via the Asset Store
● Log in and select Add to my Assets  Here
● Open a project in Unity

○ Navigate to Window -> Package Manager and select 
Packages: My Assets

○ Select Vuforia Engine and Download, then Import
○ Now you can find Vuforia Engine AR into your 

Packages

● Add ARCamera Gameobject from the Vuforia Engine menu
○ Select the ARCamera and click Open Vuforia 

Configuration
○ Select Add License and add Get Basic ( You will have 

to register), copy and paste the license key into App 
License Key on the Inspector.

Getting Started with Vuforia

https://assetstore.unity.com/packages/templates/packs/vuforia-engine-163598
https://library.vuforia.com/getting-started/getting-started-vuforia-engine-unity


PTC

Vuforia

Set up a basic AR Scene - Image Target
● GameObject → Vuforia Engine -> Image Target

○ Select Image Target and choose Type : Database on the 
Inspector and click Import 

○ Download Robot Kyle from the Unity Asset Store here and 
Import

○ Add your asset as a Child of the Image Tracker and Scale it
○ Select Image Target → Advanced → Device Tracker 

Settings -> PlayMode -> Playmode Type → Webcam
○ Print or Download to a mobile device the Image Tracker
○ Focus your webcam into the Image Tracker and press Play

Features Overview

Vuforia Demo  14

https://assetstore.unity.com/packages/3d/characters/robots/space-robot-kyle-4696
https://library.vuforia.com/getting-started/vuforia-features


PTC

Vuforia

Other Examples
● Complex Image Targets
● Virtual Buttons
● Model Targets
● And more…

Core Samples

Vuforia VFX Library

Vuforia Demo  15

https://assetstore.unity.com/packages/templates/packs/vuforia-core-samples-99026
https://library.vuforia.com/unity-extension/vuforia-vfx-library


HYPER-REALITY

Keiichi Matsuda

Watch Here!

Vuforia Demo  16

https://youtu.be/YJg02ivYzSs


 17What is XR? -> Hardware Platforms



What is XR? -> Hardware Platforms

a technology that superimposes a computer-generated 
image on a user's view of the real world, thus providing a 
composite view.

Handheld AR offers the most mainstream AR solutions 
today on social media. People may not even realize that 
the AR filters they use on Instagram are augmented reality 
experiences.

● Google Android - AR Core
● Apple IOS - ARKit

Unity for AR
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Augmented Reality - Handheld

https://unity.com/unity/features/ar


What is XR? -> Hardware Platforms

Augmented Reality - Head-mounted

Augmented Reality HMDs also known as Optical 
head-mounted displays or OHMDs. The displays of these 
devices are transparent. They allow users to see through 
them while projecting images and information in front of 
the users' eyes.

● Microsoft Hololens
● Magic Leap
● Nreal
● Lenovo A3

Intro to Unity for Hololens

Intro Unity for Magic Leap
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https://www.youtube.com/watch?v=P8og3nC5FaQ
https://youtu.be/ElOCGM9vIik


AR Fundamental Concepts

What is XR? -> Hardware Platforms  20

Light EstimationEnvironmental UnderstandingMotion Tracking



Getting started with XR in Unity → Demo  21

Let’s jump in!
SLAM Demo



PTC

Vuforia

Getting started with XR in Unity → Toolkits 

Vuforia Engine Package

SDK for mobile devices that enables the 
creation of AR applications. Available on the 
Unity Asset Store here

Vuforia Features:
● Image Tracking
● Model Tracking
● Area Tracking
● Ground Plane Detection

Resources
● Project Set Up
● Docs
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https://assetstore.unity.com/packages/templates/packs/vuforia-engine-163598#description
https://docs.unity3d.com/2017.3/Documentation/Manual/vuforia_get_started_project_setup.html
https://docs.microsoft.com/en-us/windows/mixed-reality/develop/unity/vuforia-development-overview


Niantic Lightship ARDK

Create persistent and realistic experiences. ARDK’s 
meshing feature translates the colors produced by 
the user’s camera, runs them through a neural 
network, and builds a mesh of tessellated triangles 
that create a machine-readable representation of the 
physical world. 

website | video

Getting started with XR in Unity → Toolkits  23

https://lightship.dev/products/ardk/
https://www.youtube.com/watch?v=XLI-Ka_pmiw


Niantic Lightship ARDK

What is XR? -> Hardware Platforms

Lightship Augmented Reality Developer Kit (ARDK) is the first 
product of the Niantic Lightship Platform. It is a cross-platform 
development kit that brings world understanding technology— 
depth, meshing, semantics—together with Lightship VPS and 
multiplayer services for more realistic and diverse AR experiences 
fused with the real world.

● Depth : Generate 3D depth information from a user’s 
surroundings in real time, using just the device’s camera.

● Semantic Segmentation : Easily and automatically classify 
objects, such as “ground” or “sky”, from the user’s camera 
data.

● Meshing : Build a 3D mesh representation of objects in the 
world, based on camera images.

● GameBoard : Enable smart object placement, procedural 
gameplay, and character navigation.

● Shared AR :  Users can use your app to locate and orient 
themselves in the same AR space, and then use that shared 
space to collaborate in virtual activities.

● Lightship VPS :  Use Lightship VPS to create immersive 
experiences in which your users interact with persistent, 
shareable AR content at real-world locations. With Lightship 
VPS you can place virtual objects that persist in the 
real-world and can be found and shared by others.

Documentation
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https://docs.unity3d.com/2019.4/Documentation/Manual/xr-template-ar.html


Microsoft

Mixed Reality Toolkit

Getting started with XR in Unity → Toolkits 

Microsoft MRTK3 is distributed as a set of 
packages that are imported into Unity using 
the Mixed Reality Feature Tool for Unity and 
the Unity Package Manager (UPM). 

Microsoft MRTK3 leverages the Unity XR 
Subsystem Management infrastructure for 
writing extensible modules that can help 
provide cross-platform support for features 
like speech and hand tracking.

Docs
Initial Setup for MRTK3

MRTK3 packages

Subsystems

MRTK2 to MRTK3 concept migration guide

 25

https://docs.microsoft.com/en-us/windows/mixed-reality/mrtk-unity/mrtk3-overview/
https://docs.microsoft.com/en-us/windows/mixed-reality/mrtk-unity/mrtk3-overview/setup
https://docs.microsoft.com/en-us/windows/mixed-reality/mrtk-unity/mrtk3-overview/packages/packages-overview
https://docs.microsoft.com/en-us/windows/mixed-reality/mrtk-unity/mrtk3-overview/architecture/subsystems
https://docs.microsoft.com/en-us/windows/mixed-reality/mrtk-unity/mrtk3-overview/architecture/mrtk-v2-to-v3


Microsoft MRTK

What is XR? -> Hardware Platforms

Lightship Augmented Reality Developer Kit (ARDK) is the first 
product of the Niantic Lightship Platform. It is a cross-platform 
development kit that brings world understanding technology— 
depth, meshing, semantics—together with Lightship VPS and 
multiplayer services for more realistic and diverse AR experiences 
fused with the real world.

● Input System
● Hand Tracking
● Eye Tracking
● UI Controls 
● Solvers
● Spatial Awareness 
● Speech & Dictation
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Unity

AR Foundation

Getting started with XR in Unity → Toolkits 

AR Foundation allows you to work with augmented reality 
platforms in a multi-platform way within Unity. 

This package presents an interface for Unity developers 
to use, but doesn't implement any AR features itself. To 
use AR Foundation on a target device, you also need 
separate packages for the target platforms officially 
supported by Unity:

ARCore XR Plug-in on Android
ARKit XR Plug-in on iOS
OpenXR Plug-in on HoloLens

Docs
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https://docs.unity3d.com/Packages/com.unity.xr.arcore@5.0/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.arkit@5.0/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.openxr@1.2/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@5.0/manual/index.html


AR Foundation Samples

What is XR? -> Demo  28

Download sample project via the github
● Get Project Here
● Clone or download this repository to a workspace on your drive

○ Click the ⤓ Code button on this page to get the URL to clone 
with Git or click Download ZIP to get a copy of this repository 
that you can extract

● Open a project in Unity
○ Download, install, and run Unity Hub
○ In the Installs tab, select Locate or Add to find or install Unity 

2019.4 LTS or later
○ In the Projects tab, click Add
○ Browse to the VR folder within your downloaded copy of this 

repository and click Select Folder
○ Click the project which should now be added to the list to 

open the project
● To run the AR Foundation sample on a headset, go to File > Build 

Settings and build the app. 1

Samples (v4.2)
Samples (v5)

Building for iOS

Building for Android

https://github.com/Unity-Technologies/arfoundation-samples
https://unity3d.com/get-unity/download
https://github.com/Unity-Technologies/arfoundation-samples/tree/4.2
https://github.com/Unity-Technologies/arfoundation-samples
https://docs.unity3d.com/Manual/iphone.html
https://docs.unity3d.com/Manual/android.html


Getting started with XR in Unity → Demo  29

Let’s jump in!
AR Foundations Demo

Project Assets:
https://bit.ly/R2MV_XpressoAR_assets

https://bit.ly/R2MV_XpressoAR_assets


AR Foundation Samples

What is XR? -> Demo  30

Samples (v4.2)
Samples (v5)

https://github.com/Unity-Technologies/arfoundation-samples/tree/4.2
https://github.com/Unity-Technologies/arfoundation-samples


Unity AR project template

What is XR? -> Hardware Platforms

Unity’s AR project template provides a starting point for 
augmented reality development in Unity. The template 
pre-installs the right packages needed for AR 
development, and the Scene hierarchy is pre-configured 
for AR.

Unity directly supports the following AR platforms:

● ARCore
● ARKit
● HoloLens
● Magic Leap

Documentation
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https://docs.unity3d.com/2019.4/Documentation/Manual/xr-template-ar.html


AR Foundation Packages

What is XR? -> Hardware Platforms

Create rich, deeply engaging augmented reality 
experiences with Unity’s AR Feature Set.  The AR Feature 
Set provides a starting point for augmented reality 
development, spanning from head-mounted displays to 
mobile.

● AR Foundation
● ARKit XR Plugin
● ARCore XR Plugin

● XR Plugin Management

Unity Slices Demo
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https://youtu.be/ntpthBbzK70


AR Sample Scene

What is XR? -> Hardware Platforms

The template contains a Scene named SampleScene. This 
scene contains sample materials and models. It 
additionally contains all the tutorials, and a script that 
allows you to spawn anchors through input.

You can use this Scene as a reference, or you can remove 
the example Assets from it and use it as a starting point 
for your own Project.

● AR Session
● AR Session Origin

Documentation 
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https://docs.unity3d.com/Packages/com.unity.template.ar@3.0/manual/index.html


PlaceOnPlanes script

What is XR? -> Hardware Platforms

Listens for touch events and performs an AR raycast from 
the screen touch point. AR raycasts will only hit detected 
trackables like feature points and planes.

PlaceOnPlanes.cs

AR Foundation Samples
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using System.Collections.Generic;

using UnityEngine;

using UnityEngine.XR.ARFoundation;

using UnityEngine.XR.ARSubsystems;

namespace UnityEngine.XR.ARFoundation.Samples

{

    /// <summary>

    /// Listens for touch events and performs an AR raycast from the screen touch point.

    /// AR raycasts will only hit detected trackables like feature points and planes.

    ///

    /// If a raycast hits a trackable, the <see cref="placedPrefab"/> is instantiated

    /// and moved to the hit position.

    /// </summary>

    [RequireComponent(typeof(ARRaycastManager))]

    public class PlaceOnPlane : MonoBehaviour

    {

        [SerializeField]

        [Tooltip("Instantiates this prefab on a plane at the touch location.")]

        GameObject m_PlacedPrefab;

        /// <summary>

        /// The prefab to instantiate on touch.

        /// </summary>

        public GameObject placedPrefab

        {

            get { return m_PlacedPrefab; }

            set { m_PlacedPrefab = value; }

        }

        /// <summary>

        /// The object instantiated as a result of a successful raycast intersection with a plane.

        /// </summary>

        public GameObject spawnedObject { get; private set; }

        void Awake()

        {

            m_RaycastManager = GetComponent<ARRaycastManager>();

        }

        bool TryGetTouchPosition(out Vector2 touchPosition)

        {

            if (Input.touchCount > 0)

            {

                touchPosition = Input.GetTouch(0).position;

                return true;

            }

            touchPosition = default;

            return false;

        }

        void Update()

        {

            if (!TryGetTouchPosition(out Vector2 touchPosition))

                return;

            if (m_RaycastManager.Raycast(touchPosition, s_Hits, TrackableType.PlaneWithinPolygon))

            {

                // Raycast hits are sorted by distance, so the first one

                // will be the closest hit.

                var hitPose = s_Hits[0].pose;

                if (spawnedObject == null)

                {

                    spawnedObject = Instantiate(m_PlacedPrefab, hitPose.position, hitPose.rotation);

                }

                else

                {

                    spawnedObject.transform.position = hitPose.position;

                }

            }

        }

        static List<ARRaycastHit> s_Hits = new List<ARRaycastHit>();

        ARRaycastManager m_RaycastManager;

    }

}

https://github.com/Unity-Technologies/arfoundation-samples/blob/main/Assets/Scripts/PlaceOnPlane.cs
https://github.com/Unity-Technologies/arfoundation-samples


Build Settings

What is XR? -> Hardware Platforms

Unity can build your application for different platforms and 
with different settings. This documentation describes how 
to define the scenes, target platform, and settings for 
your build.

● Android 
● iOS

Build Settings Documentation 
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https://docs.unity3d.com/Manual/BuildSettings.html


XR Plug-in Management

What is XR? -> Hardware Platforms

Support for XR hardware is delivered via plug-ins. Plug-ins 
allow you to develop for a universal XR platform so you 
don’t need to modify your project for different XR 
headsets. Supporting new XR hardware is as easy as 
adding the Plug-in Providers in Project Settings.

Currently, XR plug-ins are available for Oculus, Windows 
Mixed Reality, and Magic Leap headsets. Also included is 
the MockHMD plug-in, which allows for XR development 
without a device. It’s possible to install multiple XR 
plug-ins to support multiple headsets. In this scenario, the 
application will look for the headset supported by the first 
listed loader (covered later in this tutorial). If the headset 
is not available, the application will search for the next in 
the list, continuing through all listed loaders in order.

● ARCore
● ARKit
● Oculus
● OpenXR
● WindowMixedReality

Unity Slices Demo
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https://youtu.be/ntpthBbzK70


Setting Up the Development 
Environment for AR Applications

What is XR? -> Hardware Platforms

There are a few tools we must set up before developing 
Unity applications for either iOS or Android devices. If 
developing for iOS, this involves setting up Xcode (Apple’s 
integrated development environment (IDE)) on your 
development machine. Xcode is required to deploy our 
Unity builds onto our iOS devices.

Unity Learn Tutorial
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https://learn.unity.com/tutorial/setting-up-the-development-environment-for-ar-applications#


Universal Render Pipeline

What is XR? -> Hardware Platforms

AR Foundation supports the Universal Render Pipeline 
(URP) versions 7.0.0 or later.

Note: Projects made using URP are not compatible with 
the High Definition Render Pipeline or the built-in Unity 
rendering pipeline. Before you start development, you 
must decide which render pipeline to use in your Project.

Configuring AR Camera Background
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https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@3.0/manual/ar-camera-background-with-scriptable-render-pipeline.html


Overtime → Preview  39

Hololens Demo!

Wind Turbine Simulation

-> Porting to Hololens
-> Adding speech using Microsoft Azure!
-> Creating a custom Visual Scripting node
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 41Road to the Metaverse

Welcome to the Metaverse!

Bring your digital and physical assets into Unity

Add interactivity to your immersive experience

How to bring your real-time 3D digital twin data into Unity

Let’s get real: An introduction to AR, VR, MR, XR and more

Augmenting reality (AR): Bring digital objects into the real world

Build immersive worlds in virtual reality (VR)

Improve learning retention with immersive training experiences

Build a Microsoft HoloLens experience for training in AR 

Integrate cloud-based IoT data into your XR experience

Masterclass: Build a collaborative multi user experience

Build geolocated and social experiences in AR 

Workshops
https://create.unity.com/road-to-metaverse

https://create.unity.com/road-to-metaverse


 42Road to the Metaverse

Prototyping and world building.

Intro to Visual Scripting

Animation

Intro to Universal Render Pipeline

Intro to High Definition Render Pipeline

Shader Graph

VFX Graph

Post Processing

UI Building

Intro to VR

Intro to AR

Intro to Spatial Audio

Learn Live
https://learn.unity.com/project/road-to-the-metaverse-live

March

April

May

June

July

August

September

October

November

December

January

February

https://learn.unity.com/project/road-to-the-metaverse-live


Road to the Metaverse  43

Executive series
https://create.unity.com/road-to-metaverse#executive

https://create.unity.com/road-to-metaverse#executive


Road to the Metaverse  44

The Metaverse 
Minute
https://blog.unity.com/topic/metaverse-minute

https://blog.unity.com/topic/metaverse-minute


Road to the Metaverse  45

Road to the Metaverse: 
Forums!
https://forum.unity.com/forums/road-to-the-metaverse.798/

https://forum.unity.com/forums/road-to-the-metaverse.798/


Social
-> Please use #R2MV

 46Road to the Metaverse

Ben Radcliffe
@lightandalchemy

Jerome Maurey-Delaunay
@jeromemaurey

https://twitter.com/lightandalchemy
https://twitter.com/jeromemaurey


Q&A

Any questions?

Road to the Metaverse



Thank You 2 0 2 2

Road to the Metaverse

Survey available here!



Overtime

Road to the Metaverse



Building a Wind turbine 
Simulation, Part II

Hololens Edition!

 50
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Previously…



Mixed Reality Feature Tool

A purpose-designed user interface and expert tools to:

● Author complex, data-oriented apps 
visually 

● Test experiences without leaving the 
Unity Editor

● Deliver apps with runtime logic that 
adapt responsively to the real world 
and work across platforms

 52

Use Mixed Reality Feature Tool to discover, 
update, and add Mixed Reality feature 
packages into Unity projects. 

You can search packages by name or 
category, see their dependencies, and even 
view proposed changes to your projects 
manifest file before importing.

Download the latest version from the 
Microsoft Download Center.

Overtime -> MRTK Demo

https://docs.microsoft.com/en-us/windows/mixed-reality/develop/unity/welcome-to-mr-feature-tool


Getting started with XR in Unity → Demo  53

Let’s dive in!



Project Setup

What is XR? -> Hardware Platforms

Build settings
● UWP
● ARM 64-bit
● Use Visual Studio 2019

○ Install build tools v142
● Build and run via Device Portal

Project settings
● Make sure to check the required capabilities under 

Player -> Publish Settings
● Use .NET Framework for the latest features
● Make sure to install the Mixed Reality OpenXR 

Plugin!
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 55Overtime -> MRTK Demo

Holographic Remoting

55

Stream holographic content to your HoloLens in real time, quickly test 
and debug your app, without building and deploying a full project.

1. Download the Holographic Remoting app from the Windows Store 
on your Hololens

2. Enable Holograhic Remoting for Play Mode in Project Setting → XR 
Plug-in Management -> OpenXR

3. Click the ⚙icon to reveal the settings

There are two options for connecting:

● Wifi for wireless freedom
● USB for speed and stability

🚨 When connected via a USB cable, make sure to disable Wifi on the 
HoloLens.

Docs

https://docs.microsoft.com/en-us/windows/mixed-reality/develop/unity/unity-play-mode?tabs=openxr


Getting started with XR in Unity → Demo  56

Let’s jump in!
Live demo ahead…



Vertical turbine concept by Rifky Zaidani. 
Created in Solidworks, imported with 
Pixyz Plugin.
GrabCAD

Vertical Turbine with Solar Panels
A Microsoft Garage project provides the 
ability to visualize a 3D map within 
Unity-based projects.
Github

Maps SDK

Overtime -> MRTK Demo  57

Resources used

Import and learn about Azure Speech 
Services to enhance your learning 
experience.
Tutorial

Azure Cognitive Services

https://grabcad.com/library/vertical-turbine-with-solar-panels-1
https://github.com/microsoft/MapsSDK-Unity
https://docs.microsoft.com/en-us/training/modules/azure-speech-services-tutorials-mrtk/


Overtime -> MRTK Demo

Questions?


